22 Feb 2015
February 22, 2015

ld-linux.so.2 Error – IBM Integration Bus

February 22, 2015 Blog, IBM, IBM Integration Bus, IIB 0 Comment

During silent installation you get the following error

126

/var/apps/installs/integrationbus_developer/WebSphere_MQ

Installing IBM Integration Explorer

./install.bin: /tmp/install.dir.8848/Linux/resource/jre/jre/bin/java: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

./install.bin: line 3319: /tmp/install.dir.8848/Linux/resource/jre/jre/bin/java: Success

/var/apps/installs/integrationbus_developer/WebSphere_MQ

Installing IBM Integration Toolkit

./installToolkit-silent.sh: ./IM_Linux/installc: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

/var/apps/installs/integrationbus_developer/WebSphere_MQ

 

Solution:

  • Install libgcc.i686 as follows

# yum install ld-linux.so.2

 

Result:

 

[root@localhost sample-scripts]# yum install ld-linux.so.2

Loaded plugins: fastestmirror, langpacks

Loading mirror speeds from cached hostfile

* base: mirror.ox.ac.uk

* epel: mirror.bytemark.co.uk

* extras: mirror.ukhost4u.com

* updates: mirror.ox.ac.uk

Resolving Dependencies

–> Running transaction check

—> Package glibc.i686 0:2.17-55.el7_0.5 will be installed

–> Processing Dependency: glibc-common = 2.17-55.el7_0.5 for package: glibc-2.17-55.el7_0.5.i686

–> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-55.el7_0.5.i686

–> Processing Dependency: libfreebl3.so for package: glibc-2.17-55.el7_0.5.i686

–> Running transaction check

—> Package glibc-common.x86_64 0:2.17-55.el7_0.3 will be updated

–> Processing Dependency: glibc-common = 2.17-55.el7_0.3 for package: glibc-2.17-55.el7_0.3.x86_64

—> Package glibc-common.x86_64 0:2.17-55.el7_0.5 will be an update

—> Package nss-softokn-freebl.i686 0:3.16.2.3-1.el7_0 will be installed

–> Running transaction check

—> Package glibc.x86_64 0:2.17-55.el7_0.3 will be updated

—> Package glibc.x86_64 0:2.17-55.el7_0.5 will be an update

–> Finished Dependency Resolution

 

Dependencies Resolved

 

========================================================================================

Package Arch Version Repository Size

========================================================================================

Installing:

glibc i686 2.17-55.el7_0.5 updates 4.2 M

Installing for dependencies:

nss-softokn-freebl i686 3.16.2.3-1.el7_0 updates 175 k

Updating for dependencies:

glibc x86_64 2.17-55.el7_0.5 updates 3.6 M

glibc-common x86_64 2.17-55.el7_0.5 updates 11 M

 

Transaction Summary

========================================================================================

Install 1 Package (+1 Dependent package)

Upgrade ( 2 Dependent packages)

 

Total download size: 19 M

Facebooktwittergoogle_plusredditpinterestlinkedinmail

Leave a Reply