Introduction

The IBM Integration Bus, formerly known as the IBM WebSphere Message Broker Family, provides a variety of options for implementing a universal integration foundation based on an enterprise service bus (ESB)

In this module we discuss the installation of IBM Integration Bus (IIB) 9.0 components for starting IIB 9.0 Administration. The various components are

  1. WebSphere MQ
  2. IBM Integration Bus Component
  3. IBM Integration Bus Toolkit
  4. IBM Integration Bus Explorer

    These components can be installed separately on different operating systems and in various modes i.e. Graphical, Console and Silent modes. Graphical or GUI mode presents a series of screens i.e. a wizard that guides you through the installation process. It is suitable for developers who are used to GUI based applications. Note for Linux/Unix that the GUI mode requires an appropriate X Windows systems installed on the machine.

    Console mode is suitable when you are installing the product from a remote machine over telnet or SSH, or when security policies of an environment do not allow for a GUI approach. It presents a character based interface (CUI) and is interactive in nature. Silent mode is a non-interactive and non-GUI based way to install.

    In this course, we follow the simplest technique, where we install all the required IIB 9.0 components in one go, using silent mode.

    The installation process, at a high level involves

  5. Downloading the required software from IBM web site
  6. Preparing the machine for installation
  7. Extracting the downloaded archives and creating install images
  8. Installation using installAllSilent.sh script

Preparing a Virtual Machine

In this course, I have decided to use a Virtual Box VM, because it is free to download and use. I then prepared a CentOS 7 virtual machine with 4GB Ram and 100GB disk space. I used a bridged networking setting to ensure that the VM could be access from another client machine on the same network. By installing X2GoServer on the CentOS 7 VM using yum, I was then able to install the X2Go Client on my Windows 8 client machine. This allowed be to remotely access the VM for the purposes of installing and configuring the Linux VM from my Windows Desktop. In a commercial production environment it may not be possible to install or use a GUI, so we will cover GUI actions only make life easier for training and learning purposes. It is important to note than any server-side configuration or administration would typically be done via an SSH session. I use PuTTY to access the server via the SSH protocol

Deciding on the location of downloads

Depending on how well your Linux VM is built i.e. it has a GUI desktop, you may wish to download the required files onto a client i.e. your own workstation. Once downloaded you can SCP (using Wins SCP or equivalent via SSH) these files easily to the Linux Server.

IBM doesn’t easily publish the download locations of files so that you can use a server-side command i.e. what traditional Linux admins would do. So be aware that you may have to try more than one methods to get the required files onto your actual server VM.

Downloading the required software from IBM web site

Different flavours of the IBM Integration Bus product

IBM Integration Bus is available in different flavours. Based on our requirement we need to procure the product.

At the time of writing the home URL is:

http://www-03.ibm.com/software/products/en/ibm-integration-bus

IBM Integration Bus Advanced: Is a full-featured ESB product for any size deployment. It enables the integration of data sources from a wide range of platforms throughout service-oriented architecture (SOA) and non-SOA environments.

IBM Integration Bus Express: Is designed to meet the needs of small and midsize businesses. This entry-level ESB for simple integration projects has restricted features and is limited to one process. It can grow with your business as your integration needs evolve.

IBM Integration Bus Healthcare Pack: Provides prebuilt patterns and connections enabling rapid clinical application and device integration for more connected healthcare systems.

IBM Integration Bus Hypervisor Edition: Optimizes Integration Bus for virtualized environments. This software provides rapid provisioning of Integration Bus to private cloud environments for Red Hat Enterprise Linux and IBM AIX.

IBM Integration Bus Manufacturing Pack: The IBM Integration Bus Manufacturing Pack helps to seamlessly integrate heterogeneous It and operational manufacturing systems – making information flow more quickly and reliably.

IBM Integration Bus Retail Pack: Accelerates the development and deployment of integration between retail applications and systems, and enables transformation and enrichment of data.

IBM Integration Bus Standard: IBM Integration Bus Standard a flexible, scalable enterprise service bus for small to medium size projects.

IBM Integration Bus for z/OS: Is tightly integrated with the IBM z/OS platform. This ESB provides the same look, feel and operational characteristics as a z/OS subsystem.

Demo/Trial Editions:

A the time of writing of this chapter, IBM is providing a Demo version of IBM Integration Bus called IBM Integration Bus for Developers which is a free product download.

IBM Integration Bus for Developers is a fully licensed product available for download at no charge. The product is designed to help in the following ways:

  • Grasp basic concepts quickly through guided product examples.
  • Utilize the built-in test client to auto-generate test data or import your own to view overall and individual test results.
  • Explore all of the functionality for free, and when you are ready to upgrade, migrate your existing installations quickly with no reinstall required.

Download IBM Integration Bus 9.0 for Developers

Downloading a single file (option 1)

First let us download the core product. You need a stable broadband internet connection to download the product.

  • Download the IIB 9.0 installable from the following location

https://www14.software.ibm.com/webapp/iwm/web/pick.do?source=swg-wmbfd&S_TACT=109KA7GW&S_CMP=web_opp_integrationbus

  • Go to downloads section and click on Download

  • Select the download type. In our example we selected Linux for System x86-64 as a single file. You can choose to download a package of multiple files if you wish.

  • Click continue.
  • Fill out the questionnaire form from IBM if one is presented.
  • Read and accept the license agreement

 

Note: IBM’s website is constantly changing, so if it prompts for a required IBM ID, provide your IBM ID. If you do not have an IBM ID, register yourself and obtain an IBM ID.

At this point you can either choose to download the file using Download Director or HTTP. It is recommended to use Download Director for downloading the file. Using the download director allows for a download to be resumed if a connection to the internet is lost during the download. It saves you having to download the entire download again. It all depends on how good your internet connection is.

Note: If you have never installed a JRE on your desktop, the download director will not work and you may be prompted to install a Java Runtime Environment. If for some reason you cannot get the JRE to work on your client, then resort to using the HTTP option.

  • Select IBM Integration Bus for Linux on x86-64 9.0.0-IIB-LINUXX64-DEVELOPER.tar.gz (3.1GB) and then click the Download now button


Downloading multiple files (Scenario 2).

Alternatively if you find IBMs site crashing or downloads not completing when using the single download scenario, as I often experience myself, you can choose the multiple download option. However understand that this download option is HTTP and can take longer and your registration session can time out.


When using the multiple download option, you can download the following components individually.

Linux 64 Bit:

IBM Integration Bus (Runtime) for Linux on x86-64

9.0.0-IIB-LINUXX64-DEVELOPER-RUNTIME.tar.gz (1.14GB)

IBM Integration Bus (Toolkit) for Linux on x86-64

9.0.0-IIB-LINUXX64-DEVELOPER-TOOLKIT.tar.gz (1.95GB)

Windows 64 Bit

IBM Integration Bus (Runtime) for Windows 64 Bit

9.0.0-IIB-WINX64-DEVELOPER-RUNTIME.zip (1.24GB)

IBM Integration Bus (Toolkit) for Windows 64 Bit

9.0.0-IIB-WINX64-DEVELOPER-TOOLKIT.zip  (1.96GB)

Note: In this course we are using Linux, however you can see that there are also windows downloads.

Installing IIB 9.0 for Developers (Free version)

Once you have completed downloading the installation files, Copy the installation files to an appropriate location on your Linux server. In the context of this training course, I have installed the installation media on the file system in the following location:

/var/apps

Note: I used WinSCP a free Windows based SCP tool that allows me to easily transfer files to the Linux Server (Linux VM sunning in Virtual Box). You could employ any other SCP (Secure Copy Protocol) tools which you are familiar with, I just so happen to use WinSCP when I am using a Windows desktop.

One such example is Cygwin which is a large collection of GNU and Open Source tools which provide functionality similar to a Linux distribution on Window and then use the scp Linux shell command. Cygwin can be downloaded from the following site:

https://www.cygwin.com/

Or you may choose to download and use File-Zilla which is an Open-source (GNU GPL) FTP client for Windows, Mac OS X and GNU/Linux

https://filezilla-project.org/
  • Use the following command to expand the files:
tar -zxvf 9.0.0-IIB-LINUXX64-DEVELOPER-RUNTIME.tar.gz
tar -zxvf 9.0.0-IIB-LINUXX64-DEVELOPER-TOOLKIT.tar.gz
  • Or
gunzip ./ 9.0.0-IIB-LINUXX64-DEVELOPER-RUNTIME.tar.gz
tar -xvf

We can see below a directory listing of the decompressed installed files on my Linux Server.

Install Using GUI

We have two choices to install IIB. We can use a GUI-based wizard, or we can install silently. In this section will look at installing the product components using the GUI. Then later we will remove this installation, then install using a silent non-GUI, automated approach

To install using the GUI, we must have a Linux XWindows Session available i.e. a valid Linux GUI desktop. In my examples, I am using X2Go client to remotely access a MATE XWindows session. The server is running a standard default installation of X2GoServer. I personally find that at the time of writing of this chapter, the MATE desktop seems best for CentOS 7 remote sessions (as Gnome is not working for X2Go clients at this time) but it is up to you to choose. It is after a user-preference.

  • Change to the installation directory and run the following command:
./setuplinuxx64

Note: I have decided to use the root user as this is a local desktop VM, and not a production server. So I am not interested in Linux security settings, as these just get in the way of learning IIB. If you are installing on a commercial/production environment, I would consult the local administrators as to the correct policy for installing software i.e. sudo groups etc.

The JRE, will load and the IBM Integration Bus installer will launch as seen below.

  • Click OK to continue

  • Click Next to continue the installation

Next, we will be presented with a warning that we have not yet installed WMQ. IIB requires WebSphere MQ as its underlying message transport. We now have to install WMQ. Looking into the expanded installation files we can see that there is folder that contains the required WMQ installation files. What will do now is exit the installation and install WMQ, then re-run the GUI installation.

Note: Since in this document, we are not really concerned with describing all installation methods to the nth-degree, we will not come back and complete the GUI installation, once WMQ is installed. By following the instruction for a complete total silent install of IBM 9.0 for developers, you will be able to deduce enough information to help you with a GUI based install.

If you need further help, then you can consult the chapter called IIB9Admin_Chapter1_FullVersion_Installation_howto which covers the correct installation methods for both GUI and command line as allowed by the full licensed version of the IIB 9.0 product. It is important to note that WMQ cannot be installed using a GUI method as such. You can also consult my WMQ courses available on line from our site: http://www.themiddlewareshop.com/products

Installing WMQ

Included in the installation pack is WebSphere MQ 7.5 and IBM has provided an install all. Now a point to note is that when installing on a production system, you would likely not want to install IB Explorer (formerly WMQ Explorer) and the IB Toolkit (Formerly WMB Toolkit), which are both GUI that allows to you to manage IIB and Develop IIB applications. However since we are dealing with a development version of the product, we will most likely use a Linux desktop. Now in my writing I often refer to a Linux Server that is just my enterprise experience thinking as if I was doing an administration role. Please understand that this guide is to allow you to install a demo version, and the installation is not exactly the same process you would use for the full IIB product. In an enterprise i.e. commercial sense, we would most likely install WMQ and IIB with no GUI’s of any type. We would instead administer from the command line on a server via SSH or use a remote desktop which has the GUI’s installed.

Note: It is possible to install WMQ separately using an automated response file i.e. a silent installation, which is covered in the Full Version chapter which covers the variance of process as required if you have the fully licensed products. See the chapter called IIB9Admin_Chapter1_FullVersion_Installtion_howto.

There is no WMQ GUI option in the development version of IIB, so we have to resort to a silent installation. Which just so happens to be all prepared ready by IBM.

APPENDIX A: Troubleshooting

This section discusses some of the common issues that occur during installation of Message Broker Components.

Download Director

Download Director does not work in Chrome.

If you find that after installing a JRE that the IBM Download Director still does not work, then click on the Red X in the right-hand-top corner of the Chrome window. This will allow you to tell Chrome to allow this IBM plugin to be installed.

libgcc_s.so.1 Error

libgcc_s.so.1 must be installed for pthread_cancel to work

Solution:

  • Install libgcc.i686 as follows

# yum install libgcc_s.so.1

Result:

[root@localhost sample-scripts]# yum install libgcc_s.so.1

Loaded plugins: fastestmirror, langpacks

Loading mirror speeds from cached hostfile

* base: mirror.ox.ac.uk

* epel: mirror.bytemark.co.uk

* extras: mirror.bytemark.co.uk

* updates: mirror.ox.ac.uk

Resolving Dependencies

–> Running transaction check

—> Package libgcc.i686 0:4.8.2-16.2.el7_0 will be installed

–> Finished Dependency Resolution

Dependencies Resolved

========================================================================================

Package Arch Version Repository Size

========================================================================================

Installing:

libgcc i686 4.8.2-16.2.el7_0 updates 94 k

Transaction Summary

========================================================================================

Install 1 Package

Total download size: 94 k

Installed size: 190 k

Is this ok [y/d/N]: y

Downloading packages:

libgcc-4.8.2-16.2.el7_0.i686.rpm | 94 kB 00:00:00

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

Installing : libgcc-4.8.2-16.2.el7_0.i686 1/1

Verifying : libgcc-4.8.2-16.2.el7_0.i686 1/1

Installed:

libgcc.i686 0:4.8.2-16.2.el7_0

Complete!

ld-linux.so.2 Error

During silent installation you get the following error

126

/var/apps/installs/integrationbus_developer/WebSphere_MQ

Installing IBM Integration Explorer

./install.bin: /tmp/install.dir.8848/Linux/resource/jre/jre/bin/java: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

./install.bin: line 3319: /tmp/install.dir.8848/Linux/resource/jre/jre/bin/java: Success

/var/apps/installs/integrationbus_developer/WebSphere_MQ

Installing IBM Integration Toolkit

./installToolkit-silent.sh: ./IM_Linux/installc: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

/var/apps/installs/integrationbus_developer/WebSphere_MQ

 

Solution:

  • Install libgcc.i686 as follows

# yum install ld-linux.so.2

Result:

[root@localhost sample-scripts]# yum install ld-linux.so.2

Loaded plugins: fastestmirror, langpacks

Loading mirror speeds from cached hostfile

* base: mirror.ox.ac.uk

* epel: mirror.bytemark.co.uk

* extras: mirror.ukhost4u.com

* updates: mirror.ox.ac.uk

Resolving Dependencies

–> Running transaction check

—> Package glibc.i686 0:2.17-55.el7_0.5 will be installed

–> Processing Dependency: glibc-common = 2.17-55.el7_0.5 for package: glibc-2.17-55.el7_0.5.i686

–> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-55.el7_0.5.i686

–> Processing Dependency: libfreebl3.so for package: glibc-2.17-55.el7_0.5.i686

–> Running transaction check

—> Package glibc-common.x86_64 0:2.17-55.el7_0.3 will be updated

–> Processing Dependency: glibc-common = 2.17-55.el7_0.3 for package: glibc-2.17-55.el7_0.3.x86_64

—> Package glibc-common.x86_64 0:2.17-55.el7_0.5 will be an update

—> Package nss-softokn-freebl.i686 0:3.16.2.3-1.el7_0 will be installed

–> Running transaction check

—> Package glibc.x86_64 0:2.17-55.el7_0.3 will be updated

—> Package glibc.x86_64 0:2.17-55.el7_0.5 will be an update

–> Finished Dependency Resolution

Dependencies Resolved

========================================================================================

Package Arch Version Repository Size

========================================================================================

Installing:

glibc i686 2.17-55.el7_0.5 updates 4.2 M

Installing for dependencies:

nss-softokn-freebl i686 3.16.2.3-1.el7_0 updates 175 k

Updating for dependencies:

glibc x86_64 2.17-55.el7_0.5 updates 3.6 M

glibc-common x86_64 2.17-55.el7_0.5 updates 11 M

Transaction Summary

========================================================================================

Install 1 Package (+1 Dependent package)

Upgrade ( 2 Dependent packages)

Total download size: 19 M

IBM Integration Toolkit will not load Error

What we can do is look for message in /var/log/messages

cat messages

We see a line something like the one highlighted below

 

Feb 17 03:03:20 localhost /etc/gdm/Xsession: 00:00.70 ERROR [main] org.eclipse.equinox.log.internal.ExtendedLogReaderServiceFactory safeLogged

Feb 17 03:03:20 localhost /etc/gdm/Xsession: Could not load SWT library. Reasons:

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.eclipse/870893307/configuration/org.eclipse.osgi/bundles/268/1/.cp/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: swt-pi-gtk (Not found in java.library.path)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk.so (/home/stever/.swt/lib/linux/x86/liblibswt-pi-gtk.so.so: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.eclipse/870893307/configuration/org.eclipse.osgi/bundles/268/1/.cp/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: swt-pi-gtk (Not found in java.library.path)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk.so (/home/stever/.swt/lib/linux/x86/liblibswt-pi-gtk.so.so: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.eclipse/870893307/configuration/org.eclipse.osgi/bundles/268/1/.cp/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: swt-pi-gtk (Not found in java.library.path)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk-4234.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: /home/stever/.swt/lib/linux/x86/libswt-pi-gtk.so (/home/stever/.swt/lib/linux/x86/liblibswt-pi-gtk.so.so: cannot open shared object file: No such file or directory)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: at org.eclipse.swt.internal.Library.loadLibrary(Library.java:331)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: at java.lang.J9VMInternals.initializeImpl(Native Method)

Feb 17 03:03:20 localhost /etc/gdm/Xsession: …

Feb 17 03:03:20 localhost /etc/gdm/Xsession: The displayed failed to initialize. See the log /home/stever/.eclipse/870893307/configuration/1424142197941.log for details.

Opening this file we get the following message

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:

    /opt/IBM/IntegrationToolkit90/configuration/org.eclipse.osgi/bundles/5918/1/.cp/libswt-pi-gtk-3659.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

    swt-pi-gtk (Not found in java.library.path)

    /tmp/swtlib-32/libswt-pi-gtk-3659.so (libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory)

    /tmp/swtlib-32/libswt-pi-gtk.so (/tmp/swtlib-32/liblibswt-pi-gtk.so.so: cannot open shared object file: No such file or directory)

 

    at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)

    at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)

    at org.eclipse.swt.internal.gtk.OS.<clinit>(Unknown Source)

    at java.lang.J9VMInternals.initializeImpl(Native Method)

    at java.lang.J9VMInternals.initialize(Unknown Source)

    at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)

    at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)

    at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)

    at java.lang.J9VMInternals.initializeImpl(Native Method)

    at java.lang.J9VMInternals.initialize(Unknown Source)

    at org.eclipse.ui.internal.Workbench.createDisplay(Unknown Source)

    at org.eclipse.ui.PlatformUI.createDisplay(Unknown Source)

    at org.eclipse.ui.internal.ide.application.I

 

DEApplication.createDisplay(Unknown Source)

    at org.eclipse.ui.internal.ide.application.IDEApplication.start(Unknown Source)

    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Unknown Source)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(Unknown Source)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Unknown Source)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at org.eclipse.equinox.launcher.Main.invokeFramework(Unknown Source)

    at org.eclipse.equinox.launcher.Main.basicRun(Unknown Source)

    at org.eclipse.equinox.launcher.Main.run(Unknown Source)

    at org.eclipse.equinox.launcher.Main.main(Unknown Source)

Solution

We did not look at the dependencies required for IIB 9.0 to run on a supported platform. Below is a quick fix, however it is recommended that when you use a non-certified platform that you look up on the IIB site to find the nearest operating system that matches for example If Using CentOS 7.x then look for Redhat Enterprise Linux Enterprise (RHEL) 7. If 7 is not available then go to the next lowest OS version i.e. RHEL 6.x

Note: Here is a link to the IBM Knowledge Centre for example: http://www-01.ibm.com/support/knowledgecenter/

You can drill down the link index to find to the Integration Broker 9.0 landing page as seen in the screen capture below.

It can be hard to find a list of dependencies as IBM are certifying platforms and you have chosen to install on a non-supported platform. Though this is true, there are often many blogs on solutions and also the IBM forums can help. But let’s not deceive ourselves, it can take some time to find a solution and you have to be prepared to try and try again. Unless you have [paid for support. then blood sweat and of course hands-on experience is required.

Note: Most of the GUI issues such as when the IBM Installation Manager fails to load is because Installation Manager is a 32-bit application and requires 32-bit versions of OS system libraries. These libraries are not installed on RHEL 6.0/6.1 x86_64 (64-bit) by default. You must install these 32-bit libraries on your system before you run Installation Manager.

  • Install dependencies
yum install gtk2.i686 gtk2-engines.i686 PackageKit-gtk-module.i686 PackageKit-gtk-module.x86_64 libcanberra-gtk2.x86_64 libcanberra-gtk2.i686

Graphic Installer Error:

During Graphical mode of installation you may face the following problem

Graphical installers are not supported by the VM. The console mode will be used instead…

Solution :

This problem occurs in Linux 32-bit OS when the 32-bit libraries are missing. The installer is a 32-bit application and needs 32-bit libraries.

  • Install the 32-bit libraries as shown below
 

# yum install gtk2.i686

# yum install libXtst.i686

# yum install compat-libstdc++-33.i686

Eclipse Link File Error:

If MB Explorer installation log file has the following traces

Modify Text File – Single File: New File /opt/mqm/eclipseSDK33/eclipse/links/com.ibm.etools.wmadmin.Broker.Explorer.link

Status: ERROR

Additional Notes: ERROR – java.io.FileNotFoundException: parent did not exist when attempting touch on path: /opt/mqm/eclipseSDK33/eclipse/links/com.ibm.etools.wmadmin.Broker.Explorer.link

Solution:

  • Create “links” directory under /opt/mqm/eclipseSDK33/eclipse to avoid the issue given above

libImbCmdLib.so Error

[mqm@localhost ~]$ mqsicreatebroker Brk01Verify -q QMVerify02

mqsicreatebroker: error while loading shared libraries: libImbCmdLib.so: cannot open shared object file: No such file or directory

 

If you get this error, it is because you have not set an appropriate IB environment see, mqsiprofile command mentioned earlier in this document.

Facebooktwittergoogle_plusredditpinterestlinkedinmail

Leave a Reply